On Mon, May 20, 2019 at 2:42 PM Vojtech Juranek <vjuranek@redhat.com> wrote:
On neděle 19. května 2019 20:49:34 CEST Nir Soffer wrote:
> -PyMODINIT_FUNC
> -initsanlock(void)
> +static int
> +module_init(PyObject* m)

IMHO `module` instead of `m` would be better name. In general, I'd avoid one
letter names (but probably fine when used as local variables in short
functions like in `initsanlock()` where it's easy to find all occurrences by
reading few lines of code)

I agree with this approach, and it matches the way we use the module
in module_init() and in the init functions.

Nir