On Tue, 2004-11-30 at 13:32 +0000, Luciano Miguel Ferreira Rocha wrote:
pango-1.6.0-7.src.rpm, in rawhide (I assume it's the same in FC3) has
a BuildRequires: xorg-x11-devel >= 4.2.99
OTOH, the -devel package has a Requires: XFree86-devel >= 4.2.99
FC3 ships with xorg-x11-devel 6.8.1, so, obviously, it satisfies the
BuildRequires. YDL 4 still uses 0.0.6.6-0.0.2004_03_11.9, that does provide
"XFree86-devel = 4.4.0", but not xorg-x11-devel >= 4.2.99.
As there never was a xorg-x11 4.2.99, and the devel package specifies
XFree86, I guess the BuildRequires line should be changed to
"XFree86-devel >= 4.2.99", no?
Certainly file a bug. Though I almost certainly will change the
requires to be on xorg-x11-devel with a recent version... my
general policy is that if I touch a Requires or a BuildRequires
I'll update it to something I'm pretty sure has been tested,
and I haven't tested recent Pango versions with XFree86-4.3.0.